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单片机技术及应用是高等职业院校电类专业的一门实用性很强的技能实践课程。本书

结合高等职业院校对学生的技能要求,采用任务导入、任务分析、任务实施的模式组织内容,
将知识点和技能点融为一体,采用教、学、做一体化的教学模式,充分体现了理实结合的职业

教育特色。
衡水职业技术学院“单片机技术及应用”课程组在河北省在线精品课程建设项目的基础

上,依据《国家职业教育改革实施方案》和《职业院校教材管理办法》等文件精神,结合多年教

学改革的成果与经验,编写了在线课程“单片机技术及应用”的配套教材。本书的编写特色

如下。

1.教学内容紧密对接专业标准

编者对教学内容进行了重构,保证教学内容适度、够用,避免了难度过大、内容冗杂。

2.教学设计充分体现职教特点

本书采用了大量实际案例,做到步步有任务,节节有训练。每个知识点都设有相应的实

操,做到教、学、做有机统一,非常适合学生学习和实践。

3.教学案例紧密联系生活实际

本书选取的案例贴近生产生活实际,任务仿真和实操也比较容易上手,使枯燥的理论学

习变得生动形象,利于学生理解和掌握。

4.任务评价注重学生职业素养

本书采用对学生完成的任务进行评价的方式,并利用详细的学生任务评价表将知识、技
能、职业素养、合作精神都融入评价范围,旨在促进学生职业能力和创新精神的全面发展,体
现了高等职业院校育人的特点。

5.将C语言学习有机融入教学案例

本书采用C语言编程,将C语言学习融入教学案例中,以单片机为平台进行C语言教

学,使两者相得益彰。

6.任务化设计突出实用性

本书中引用了很多单片机应用的小实例,并以任务引入、任务目标、任务分析、知识链

接、任务实施、任务评价和任务拓展的形式展现。书中任务涵盖了C51程序设计的基本语

法、语句和应用方法,涉及的知识点由易到难、循序渐进,突出可行性和实用性。

7.数字教学资源助力课堂教学

本书依托“智慧职教”教学平台,形成了立体化的数字教学资源,包括微课视频、PPT、练
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习题库、配套软件等。学生可登录平台进行在线学习,也可通过扫描书中的二维码观看微课

视频学习。本书配套的教学资源可在平台的课程页面在线浏览或下载,既方便学生进行自

学,也方便教师采用“线上线下”融合的教学模式,提高信息化教学水平。
本书参考学时为64学时,具体安排见下表。实际使用时,不同学校可根据具体教学情

况增减学时。

课  题 课 程 内 容 理 论 学 时 实 践 学 时

一 单片机的初步认知 2 4

二 交通信号灯的设计与制作 2 6

三 按键与数码管的应用设计 2 8

四 中断系统的应用 2 8

五 LED点阵显示设计 2 4

六 你来我往双机通信 2 4

七 液晶显示系统设计 2 4

八 可控的电机 2 4

九 模数和数模转换 2 4

总计 64

本书由衡水职业技术学院曹月真担任主编,衡水职业技术学院薛鹤娟和王素芹担任副主

编。曹月真对本书的编写思路与大纲进行了总体策划,对全书统稿,并编写了课题一至课题

八。薛鹤娟和王素芹协助完成了统稿工作,薛鹤娟编写了课题九,王素芹编写了本书内容提

要、前言及思考与练习题。微课视频教学课程由曹月真、薛鹤娟、王素芹主讲。本书由衡水职

业技术学院李敏教授主审。李敏教授在审稿过程中提出了许多宝贵的意见和建议,在此深

表感谢!
由于编者水平有限,书中难免存在不足之处,敬请读者批评指正。

编 者
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课题一 单片机的初步认知
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单片机具有性能高、速度高、体积小、价格低、可重复编程等优点,被广泛应用于

多个领域,如智能仪器仪表、工业监控、计算机网络和通信、家用电器、医疗设备、汽

车设备、军用机械等。单片机系统包括硬件电路设计和软件设计两部分,采用C语

言编程,其硬件仿真平台为Proteus软件。

任务一 搭建单片机最小系统

单片机最小系统也称单片机最小应用系统,是指采用最少元器件组成的能够使单片机

工作的系统。

知识目标

(1)了解单片机的硬件结构。
(2)认识单片机的引脚。
(3)学会搭建单片机最小系统的硬件电路。
技能目标

(1)能熟练查阅常用电子元器件和芯片的规格、型号、使用方法等技术资料。
(2)能用Proteus仿真软件对单片机最小系统的硬件电路进行仿真。
素养目标

(1)培养严谨的工程思维与问题解决能力。
(2)提升自主学习与持续学习的能力。

单片机最小系统主要由电源电路、复位电路和时钟电路组成。在搭建单片机最小系统

的硬件电路之前,需要先认识单片机的内部结构以及引脚图。
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微课堂

单片机的认知

一、认识单片机

1.什么是单片机

单片机是使用超大规模集成电路技术把具有数据处理能力的中央

处理器、随机存储器(数据存储器)、只读存储器(程序存储器)、I/O口、
中断系统和定时/计数器等集成到一块硅片上的微型计算机系统,在工

业控制、航空航天等领域被广泛应用。根据中央处理器的处理能力,单
片机可分为4位、8位、16位、32位单片机。本书以8位基本型单片机AT89C51为研究对象

来详细介绍单片机的内部结构、工作原理及应用。AT89C51单片机的外形如图1-1所示。

图1-1 AT89C51单片机的外形

2.单片机的内部结构

AT89C51单片机的内部结构如图1-2所示。

图1-2 AT89C51单片机的内部结构
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1)中央处理器

中央处理单元又称CPU,是单片机的核心,它由运算器和控制器等部件组成。

2)存储器

AT89C51单片机的程序存储器和数据存储器有各自的寻址系统。程序存储器用来存

放程序和表格常数,通过16位地址总线进行寻址,可寻址的地址空间为64KB。数据存储器

常用来存放程序运行中所需要的常数或变量,分为内部RAM 和外部RAM,最大可扩展的

地址空间同样为64KB。

3)定时/计数器

AT89C51单片机内部有两个16位可编程的定时/计数器。

4)中断系统

AT89C51单片机的中断系统共有五个中断源,包括两个外部中断、两个定时/计数器中

断和一个全双工的异步串行口中断。

5)时钟电路

AT89C51单片机内部的时钟电路为单片机提供时钟脉冲。单片机工作时的晶体振荡

器(晶振)频率通常为11.0592MHz或12MHz。

6)I/O口

AT89C51单片机有四个并行I/O口,分别为P0、P1、P2、P3,每个I/O口有八个引脚,能
够实现数据的并行输入和输出。

3.单片机的引脚

AT89C51单片机采用40引脚的双列直插封装方式。图1-3所示为AT89C51单片机的

引脚图。

图1-3 AT89C51单片机的引脚图

AT89C51单片机各引脚功能如下。

1)电源引脚

GND(某些品牌单片机的此引脚名称为VSS):接地。
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VCC:接+5V电源。

2)时钟引脚

XTAL1:内部振荡电路反相放大器的输入端。当单片机使用内部振荡器时,此引脚外

接晶振的一个引脚;当单片机使用外部振荡器时,此引脚接外部振荡源。

XTAL2:内部振荡电路反相放大器的输出端。当单片机使用内部振荡器时,此引脚外

接晶振的另一个引脚;当单片机使用外部振荡器时,此引脚悬空。

3)控制引脚

RST:当单片机运行时,此引脚上出现持续时间大于两个机器周期的高电平(由低到高

跳变),将使单片机复位。

ALE:单片机正常运行时,此引脚用于将地址的低字节锁存到外部地址锁存器中,ALE
引脚以不变的频率(时钟振荡频率的1/6)周期性地发出正脉冲。因此,它可用于对外输出时

钟,也可用于定时目的。但要注意,每当访问外部数据存储器时,系统将跳过一个 ALE
脉冲。

对于可擦可编程只读存储器(EPROM)型单片机,在对EPROM 编程期间,此引脚接收

编程脉冲。

PSEN:外部程序存储器读选通信号输出端。当系统从外部程序存储器读取指令(或数

据)时,PSEN接外部程序存储器的输出允许端。

EA:EA为内部程序存储器和外部程序存储器选择引脚。当EA为高电平时,系统访问

内部程序存储器,如果PC值大于0FFFH,系统将自动转向地址以1000H开始的外部程序

存储器。当EA为低电平时,系统直接访问地址为0000H~FFFFH的外部程序存储器。

4)输入/输出引脚

P0口(P0.0~P0.7):一个八位漏极开路型双向I/O口。当系统访问外部存储器时,P0
口是分时传送数据的低八位地址总线和数据总线。P0口作为普通I/O口使用时需外接上

拉电阻,能驱动八个LS型TTL负载。

P1口(P1.0~P1.7):一个带有内部上拉电阻的八位准双向I/O口,能驱动四个LS型

TTL负载。

P2口(P2.0~P2.7):一个带有内部上拉电阻的八位准双向I/O口。当系统访问外部存

储器时,P2口输出高八位地址。P2口可以驱动四个LS型TTL负载。

P3口(P3.0~P3.7):一个带有内部上拉电阻的八位准双向I/O口,能驱动四个LS型

TTL负载。P3口还具有第二功能,P3口各引脚第二功能的定义见表1-1。

表1-1 P3口各引脚第二功能的定义

P3口引脚 第二功能定义 功 能 说 明

P3.0 RXD 串行输入口

P3.1 TXD 串行输出口

P3.2 INT0 外部中断0输入端

P3.3 INT1 外部中断1输入端



5    

续表

P3口引脚 第二功能定义 功 能 说 明

P3.4 T0 T0外部计数脉冲输入端

P3.5 T1 T1外部计数脉冲输入端

P3.6 WR 外部RAM写选通脉冲输出端

P3.7 RD 外部RAM读选通脉冲输出端

二、时钟与时序

单片机系统中的各个部件在一个统一的时钟脉冲控制下有序地进行工作,时钟电路是

单片机系统最基本、最重要的电路。

1.时钟

AT89C51单片机内部有一个高增益反相放大器,引脚XTAL1和XTAL2分别是该放

大器的输入端和输出端。在引脚XTAL1和XTAL2两端跨接晶振或陶瓷振荡器可构成稳

定的自激振荡电路,该振荡电路的输出信号可直接送入内部时序电路。AT89C51单片机的

时钟信号可通过两种方式产生,即内部时钟方式和外部时钟方式。

1)内部时钟方式

内部时钟方式是指由单片机内部的高增益反相放大器和外部跨接的晶振(或陶瓷振荡

器)、微调电容构成的时钟电路产生时钟信号,其工作原理如图1-4所示。

图1-4 内部时钟方式

当XTAL1、XTAL2外接晶振时,C1、C2的值通常为30pF左右;C1、C2对晶振的频率有

微调作用,晶振的频率可在1.2~12MHz范围选择。由于内部时钟方式的时钟电路接线简

单,因此单片机系统大多采用这种方式。

内部时钟方式产生的时钟信号的频率就是晶振的固有频率,常用fosc表示。如果选择

12MHz晶振,则fosc=12×106Hz。

2)外部时钟方式

外部时钟方式是指利用单片机外部时钟电路产生时钟信号。外部时钟方式产生的时钟
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信号直接由XTAL1引脚输入单片机,此时XTAL2引脚悬空,如图1-5所示。

图1-5 外部时钟方式

2.时序

时序是用定时单位来描述的,AT89C51单片机的时序单位有四个,分别是节拍、状态、

机器周期和指令周期。

当执行指令时,CPU都是按照一定顺序进行的。由于指令的字节数不同,因此CPU执

行指令所需要的时间也就不同。即使是字节数相同的指令,CPU执行指令所需要的时间也

会因执行操作的不同而有很大差别。

1)节拍与状态

振荡脉冲的周期定义为节拍,为方便描述,一般用P表示。在AT89C51单片机中,一个

状态等于两个节拍,用S表示。前半周期相应的节拍定义为P1,后半周期对应的节拍定义

为P2。

2)机器周期

完成一个最基本操作(读或写)所需要的时间称为机器周期。AT89C51单片机的机器

周期是固定的,一个机器周期有6个状态,表示为S1~S6,而一个状态包含两个节拍,那么

一个机器周期就有12个节拍,可以记为S1P1,S1P2,…,S6P1,S6P2。一个机器周期共包含

12个振荡脉冲,即机器周期就是振荡脉冲的12分频。若单片机采用6MHz的时钟频率,则

一个机器周期为2μs;若单片机采用12MHz的时钟频率,则一个机器周期为1μs。

3)指令周期

指令周期是执行一条指令所需要的时间,一般由若干个机器周期组成。指令不同,所需

要的机器周期数也不同。对于一些简单的单字节指令,指令周期可能和机器周期时间相同;

而对于一些比较复杂的指令,如乘、除运算等则需要4个机器周期才能完成,这时指令周期

大于机器周期。

通常,一个机器周期即可完成的指令称为单周期指令,两个机器周期才能完成的指令称

为双周期指令。AT89C51单片机中的大多数指令都是单周期或双周期指令,只有乘、除运

算为四周期指令。AT89C51单片机的指令时序图如图1-6所示。
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图1-6 AT89C51单片机的指令时序图

三、复位系统

单片机在上电时一般都需要进行一次复位操作,以便使芯片内的一些部件处于一个确

定的初始状态。复位是一种很重要的操作,一般部件本身不具有自动上电复位功能,需要借

助外部复位电路提供的复位信号才能进行复位操作。除正常初始化之外,当程序运行出错

或操作错误使系统处于锁死状态时,也需要通过复位按键使AT89C51单片机摆脱“跑飞”或
锁死状态而重新启动。

AT89C51单片机的第9脚(RST)为复位引脚。单片机上电后,时钟电路开始工作,只
要RST引脚上持续出现大于两个机器周期的高电平即可引起单片机执行复位操作。单片

机复位后,PC=0000H,CPU从程序存储器的0000H开始执行指令。单片机中的特殊功能

寄存器(SFR)的复位状态表如表1-2所示。

表1-2 特殊功能寄存器复位状态表

特殊功能寄存器 复位状态 特殊功能寄存器 复位状态

PC 0000H TMOD 00H

ACC 00H TCON 00H

B 00H TH0 00H

PSW 00H TL0 00H

SP 07H TH1 00H

DPTR 0000H TL1 00H

P0~P3 FFH SCON 00H

IP XXX00000B SBUF 不定

IE 0XX00000B PCON 0XXX0000B

单片机的外部复位电路有上电复位和按键复位两种。
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1)上电复位电路

最简单的上电复位电路由电容和电阻串联构成,如图1-7所示。图中标示的参数为晶

振为6MHz时各元器件的参数。

2)按键复位电路

图1-8所示为按键复位电路,图中标示的参数是晶振为6MHz时各元器件的参数。当

按下复位按键后,电容迅速通过R2放电,放电结束时的VR=(R1×VCC)/(R1+R2)。由于

R1远大于R2,所以VR非常接近VCC,这使RST引脚处于高电平状态。松开复位按键后,过
程与上电复位电路相同。

图1-7 上电复位电路 图1-8 按键复位电路

参照图1-9搭建单片机最小系统的硬件电路回答问题。

图1-9 单片机最小系统的硬件电路
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(1)通常情况下单片机的工作电压是多少?
(2)9号引脚为高电平还是低电平? 系统可以实现复位吗?
(3)组成单片机最小系统的元器件有哪些?

学生任务评价表如表1-3所示。

表1-3 学生任务评价表

任务时间

任务名称 评分内容及标准 满分 得分 评价

搭建单片机

最小系统

1.课堂状态(非常好10分,一般5分,不好3分)

2.任务完成情况(非常好10分,一般5分,不好3分)

3.任务完成的主动性(积极10分,不积极5分)
30分

自我评价:

1.准时参加任务实施(准时10分,不准时5分)

2.积极参与任务交流讨论(积极10分,不积极5分)

3.准确说出任务设计流程与方法(准确10分,不准确5分)

4.团队合作情况(非常好10分,一般5分,不好3分)

40分

小组评价:

1.电路设计与绘制情况(非常好10分,一般5分,不好3分)

2.遵守安全操作规程(遵守10分,不遵守5分)

3.工作台及场地卫生情况(非常好10分,一般5分,不好3分)
30分

教师评价:

总计

Proteus软件的使用步骤和方法如下。

1.启用Proteus编辑环境

在计算机中安装好Proteus软件后,然后执行“开始菜单”→“所有程序”→“Proteus7

Professional”命令,单击图标 即可启动程序,启动界面如图1-10所示。

图1-10 Proteus启动界面
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系统进入启动界面2~3s后,弹出编辑操作ISISProfessional窗口,如图1-11所示。

图1-11 ISISProfessional窗口

2.选择元器件

在工具箱中单击元器件按钮图标后,系统才会弹出元器件及元器件库选择按钮,如图1-12
所示。其中“P”为元器件选择按钮,“L”为元器件库选择按钮。

图1-12 元器件及元器件库选择按钮

单击“P”按钮,弹出一个对象选择对话框,在此对话框的“Keywords”文本框中输入元器

件名称,单击“OK”按钮就可以从库中选择元器件,并且所选元器件名称将在对象选择器中

显示。
例如,在“Keywords”文本框中输入“at89C”,“Results”选项区将显示出若干个匹配的

AT89C51,如图1-13所示。然后双击需要的元器件就可以将其添加到对象选择器中,在其

列表中可以看到选中元器件的名称。

3.放置、移动、旋转、删除元器件

1)放置元器件

经过前面两步将所需要的元器件添加到对象选择器后,单击要放置的元器件,如LED-
RED,此时蓝色条(见图1-14框线所示)出现在该元器件名字上,再在原理图编辑窗口任意

位置单击,就将LED-RED放置到原理图编辑窗口中了。



11   

图1-13 元器件浏览对话框

图1-14 元器件选中状态

2)移动元器件

将元器件放置到原理图编辑窗口中后,若要移动元器件,应先单击元器件,使元器件处

于选中状态(默认情况下为红色),再按住鼠标左键拖动,元器件就会跟随鼠标移动,到达合

适位置时,松开鼠标左键即可。

3)旋转元器件

放置元器件前,先单击要放置的元器件,再单击方向工具栏中相应的转向按钮即可旋转

元器件,然后在原理图编辑窗口中单击,就将一个已经更改方向的元器件放置到原理图编辑

窗口中了。
若要在原理图编辑窗口中更改元器件方向,则应右击选中该元器件,在弹出的对话框中
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输入要旋转的角度即可。

4)删除元器件

若要在原理图编辑窗口中删除元器件,则右键双击该元器件就可删除元器件,或者先单

击选中该元器件,再按下Delete键也可删除元器件。
通过放置、移动、旋转、删除操作,可将各元器件放置在原理图编辑窗口的合适位置。

4.放置电源、地

1)放置电源

单击工具箱中的元器件终端图标,在对象选择器中单击“POWER”,其选中状态如图1-15
所示,再在原理图编辑窗口的合适位置单击就将电源放置在原理图编辑窗口中了。

图1-15 电源选中状态

2)放置地

单击工具箱中的元器件终端图标,在对象选择器中单击“GROUND”,再在原理图编辑

窗口的合适位置单击就可将地放置在原理图编辑窗口中了。

5.布线

原理图编辑窗口中没有专门的布线按钮,但系统默认自动布线按钮有效,因此可直接画线。

1)在两个对象之间连线

使光标靠近一个对象的引脚末端,在该处单击,移动鼠标使光标靠近另一个对象的引脚

末端,在该处再次单击,就可以画一条连线。如果想手动设定走线路径,应拖动鼠标在想要

拐弯处单击,到达画线端的另一端再次单击,就可画好一条连线。在拖动鼠标的过程中,按
住Ctrl键,在画线端的另一端单击,即可手动画一条任意角度的连线。

2)移动画线

右击画线,弹出菜单,选择“DragWire”选项,此时画线变成黄色。拖动鼠标,该线就跟

随鼠标移动。若要同时移动多条画线,应先框选这些画线,再单击移动按钮,将画线拖动到

合适的位置处单击就可以改变画线的位置。

3)总线及分支线的画法

画总线:可以把已经画好的单线设置为总线,选中该线,右击,在弹出的菜单中选择“Edit
WireStyle”选项,在“GlobalStyle”下拉列表中选择“WIRE”,然后单击“OK”按钮即可,如图1-16
所示。

画分支线:使光标靠近一个对象的引脚末端,在该处单击,然后拖动鼠标,在总线上单击即

可画好一条分支线。若要使分支线与总线成任意角度,要同时按住Ctrl键,再在总线上单击。
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图1-16 编辑画线样式对话框

6.设置、修改元器件属性

在需要修改的元器件上右击,然后在弹出的菜单中选择“EditProperties”选项或按快捷

键Ctrl+E,弹出“EditComponent”对话框,在此对话框中可设置元器件属性。如果需要成组

设置元器件属性,可以使用属性分配功能,用鼠标左键框选所需要设置的所有的元器件,执行

“Tools”→“PropertyAssignmentTool”命令,或者按快捷键A,弹出图1-17所示的属性分配对

话框,然后在此对话框中可设置所选元器件的属性。

图1-17 属性分配对话框

任务二 单片机控制LED点亮

单片机最小系统硬件电路搭建好之后就可以利用单片机控制输入输出设备了,最简单

的输出设备是LED。本任务的目标就是利用单片机控制LED点亮。

知识目标

(1)学会分析单片机I/O口高低电平状态对应的LED亮灭情况。
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(2)学会搭建单片机控制LED点亮的硬件电路。
(3)学会使用单片机任意I/O口控制LED亮灭。
技能目标

(1)能用Keil软件编写程序并成功编译生成目标文件。
(2)能用Proteus仿真软件对单片机控制LED点亮的硬件电路进行仿真。
素养目标

(1)参与小组讨论,树立团队合作意识,提高沟通技巧。
(2)培养自主学习能力与持续学习的能力。

本任务的仿真环节在Keil和Proteus软件上完成,使用Keil软件编写控制程序,将编译

好的目标文件烧录到单片机中,实现点亮LED的功能。实物的搭建可在AT89C51单片机

实训板上完成。

一、Keil软件的使用方法

Keil软件是众多单片机应用开发软件之一,它集编辑、编译、仿真于一体,支持汇编语言

和C语言的程序设计,界面友好,易学易用。下面以“点亮一盏灯”为例,说明Keil软件的基

本使用方法。

1.创建一个工程

(1)进入Keil软件的编辑界面后,执行“Project”→“NewProject”命令,如图1-18所示。

图1-18 新 建 工 程

(2)在弹出的“CreateNewProject”对话框中选择要保存的路径,输入工程文件的名字。
例如,将工程文件保存到C51目录并命名为“点亮一盏灯”,如图1-19所示,然后单击“保存”
按钮。

(3)保存工程文件后会弹出单片机型号选择对话框。Keil软件几乎支持所有AT89C51
内核的单片机,用户可以根据需要选择不同型号的单片机。对话框左侧的“Database”下拉

列表里会显示出AT89C51系列单片机的生产厂商,展开各生产厂商对应的选项,即可看到

该生产厂商生产的单片机型号。这里以Atmel公司的AT89C51为例来说明如何选择单片

机型号。首先选择生产厂商“Atmel”,展开“Atmel”选项后,列表框显示80C32E、AT48801



15   

等多种单片机型号。在列表框中选择“AT89C51”选项,右边的“Description”文本框中就会出

现对这款单片机的功能描述,如图1-20所示,然后单击“OK”按钮。

图1-19 “CreateNewProject”对话框

图1-20 单片机型号选择对话框

(4)完成单片机型号选择后,系统进入图1-21所示工程创建完成界面。此时标题栏上

显示的名称为“点亮一盏灯”,即创建的工程名称。

图1-21 工程创建完成界面

2.向工程中添加文件

(1)执行“File”→“New”命令,新建文件,如图1-22所示。新建文件后系统进入程序编

写界面,如图1-23所示。
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图1-22 新 建 文 件

图1-23 程序编写界面

(2)保存文件时,可执行“File”→“SaveAs”命令,系统会弹出“SaveAs”对话框,如图1-24所

示。在“文件名”文本框中输入文件名,同时,必须输入正确的扩展名。
注意:如果选用C语言编写程序,则扩展名为“.c”;如果选用汇编语言编写程序,则扩展

名为“.asm”。输入文件名后,单击“保存”按钮。

图1-24 文件保存对话框

(3)回到程序编写界面后,展开“Target1”选项,会出现“SourceGroup1”选项,右击该

选项,在图1-25所示快捷菜单中选择“AddFilestoGroup̍ SourceGroup1̍ ...”选项,弹出

“AddFilestoGroup̍ SourceGroup1̍ ...”对话框,选择“text”文件,然后单击“Add”按钮将

文件添加到工程中,如图1-26所示。
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图1-25 添加文件界面

图1-26 添加文件对话框

这时在“SourceGroup1”选项下多出一个子项“text.c”,如图1-27所示。子项的多少与

所增加的程序的多少保持一致。

图1-27 文件添加完成后的界面

3.项目输出设置

右击图1-28所示项目文件夹“Target1”,弹出项目功能菜单,选择“OptionsforTarget
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T̍arget1̍ ...”选项,弹出项目选项设置窗口。选择“Output”选项卡,如图1-29所示,选中

“CreateHEXFile”复选框,就可以输出HEX文件到指定的路径中。

图1-28 项目选项设置窗口

图1-29 输出HEX文件界面

4.编写C语言程序

在程序编辑文本框中编写C语言程序,如图1-30所示。在编写程序时,Keil软件会自

动识别关键字,并用不同的颜色提示用户加以注意,这样会减少编写错误,有利于提高编程

效率。

图1-30 编 写 程 序



19   

5.编译程序

执行“Project”→“BuiltTarget”命令(使用快捷键F7)或单击图1-31框线所示图标编译

程序。当界面显示“creatinghexfilefrom"点亮一盏灯"...”时说明程序没有语法错误,成
功生成了目标文件。程序编译成功界面如图1-32所示。

图1-31 程 序 编 译

图1-32 程序编译成功界面

以上操作是在Keil软件环境下创建一个完整工程的全过程,但这只是单片机系统的软

件开发过程,接下来利用Proteus软件与Keil软件进行联调仿真。

二、Proteus与Keil软件的联调仿真

在Proteus元件库中找到需要的元器件,连接好硬件电路,双击芯片弹出图1-33所示对

话框。此时“ProgramFile”一栏为空,单击文件夹图标,找到需要烧录的目标文件,如图1-34所

示。双击文件,“ProgramFile”一栏显示即将烧录的目标文件,单击“OK”按钮即可完成程序烧

录,如图1-35所示。之后就可以进行两种软件的联调仿真了。

图1-33 程序烧录设置



20   

图1-34 查找目标文件

图1-35 选中目标文件

1.常用元器件名

RES:电阻。
CAP:电容。
CRYSTAL:晶振。

RESPACK:电阻排。

LED:发光二极管。
SWITCH:刀开关。

BUTTON:按钮。
DIODE:二极管。

NPN、PNP:三极管。
BUZZER:蜂鸣器。

ELECTRO:电解电容。

Matrix:8×8点阵。

2.常用快捷键

F8:当前工作区全部显示。
F6:放大,以鼠标为中心放大。

F7:缩小,以鼠标为中心缩小。
G:栅格开关。

O:重新设置原点,将鼠标指向的点设为原点。

U:撤销键。

一、编写程序,并在Keil中生成目标文件

单片机控制LED点亮的程序如下。



21   

#include<reg51.h>
sbitled1=P1̂0;

voidmain()
{

led1=0;

while(1);
}

(1)程序第一行为头文件包含,reg51.h头文件中使用了sbit关键字。程序第一行也可

写成#include“reg51.h”。
(2)sbit关键字用于定义特殊功能寄存器中可以位寻址的相应位,在这里将P1口的

P1.0命名为“led1”。
(3)一个C51程序有且只有一个main函数,其函数体用{}括起来。
(4)给led1赋值0,即给P1.0赋值0,单片机输出低电平,LED点亮。
(5)while(1)为条件循环语句,1代表条件为真,即永真循环,也就是无限循环,语句后面

加了“;”,表示语句结束,即原地踏步。
程序编写完成后,单击Keil工具栏中的“Built”图标,当软件下面的状态栏显示creating

hexfile时,表示目标文件已经生成。

二、在Proteus中搭建硬件电路,实现软件仿真

单片机控制LED点亮的硬件电路如图1-36所示。该硬电路需要用到的元器件有单片机、
晶振、电容、电解电容、电阻、发光二极管。连接好硬件电路,烧录Keil软件生成的目标文件。

图1-36 单片机控制LED点亮的硬件电路

将目标文件成功烧录至单片机中,然后单击Proteus软件左下角的“播放”按钮 ,即
可看到仿真效果,如图1-37所示(此图省略单片机最小系统电路)。


